Cloud Fax services North America were experiencing a degradation in service.
Incident Report for OpenText
Resolved
The following services were experiencing experience degraded service. The issue is now resolved. We appreciate your patience.

- Fax2Mail
- Production Messaging
- RightFax Connect

Tracking Number: IM3439515
Posted Mar 22, 2024 - 22:03 UTC
Update
OpenText Fax2Mail and RightFax Connect customers may experience degraded service when receiving incoming fax transactions. Teams are currently assembled and working to resolve the issue. We appreciate your patience.

- Fax2Mail
- Production Messaging
- RightFax Connect

Tracking Number: IM3439515
Posted Mar 22, 2024 - 21:25 UTC
Update
OpenText Fax2Mail and RightFax Connect customers may experience degraded service when receiving incoming fax transactions. Teams are currently assembled and working to resolve the issue. We appreciate your patience.

- Fax2Mail
- Production Messaging
- RightFax Connect

Tracking Number: IM3439515
Posted Mar 22, 2024 - 20:27 UTC
Update
OpenText Fax2Mail and RightFax Connect customers may experience degraded service when receiving incoming fax transactions. Teams are currently assembled and working to resolve the issue. We appreciate your patience.

- Fax2Mail
- Production Messaging
- RightFax Connect

Tracking Number: IM3439515
Posted Mar 22, 2024 - 19:26 UTC
Investigating
OpenText Fax2Mail and RightFax Connect customers may experience degraded service when receiving incoming fax transactions. Teams are currently assembled and working to resolve the issue. We appreciate your patience.

- Fax2Mail
- Production Messaging
- RightFax Connect

Tracking Number: IM3439515
Posted Mar 22, 2024 - 18:27 UTC
This incident affected: Cloud Fax services North America (Fax2Mail, Production Messaging, RightFax Connect).